diff setup.py @ 3:53a61865e86e draft

planemo upload for repository https://github.com/COMBAT-TB/confil commit cb48efaef286f70c94607cb583a61bb9e3d71604
author sanbi-uwc
date Wed, 27 Feb 2019 06:20:05 -0500
parents
children eaf51f9aff10
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Wed Feb 27 06:20:05 2019 -0500
@@ -0,0 +1,23 @@
+from setuptools import find_packages, setup
+
+with open("README.md", "r") as fh:
+    long_description = fh.read()
+
+setup(
+    name='confil',
+    version='0.0.1',
+    url='https://github.com/COMBAT-TB/confil',
+    description='Contamination filter',
+    long_description=long_description,
+    long_description_content_type="text/markdown",
+    keywords='contamination, filter',
+    py_modules=['confil'],
+    packages=find_packages(),
+    include_package_data=True,
+    install_requires=[
+        'click'
+    ],
+    entry_points={
+        'console_scripts': ['confil=confil.confil:confil']
+    },
+)